




  RhinoScan                                           Trouble-Shooting

     89     

Chapter 10 Trouble-Shooting

IN THIS CHAPTER If you recieve an error message, this chapter contains some methods to solve the 
problem. 

10.1 Viewing the System Log

WHAT IS THE SYSTEM 
LOG?

The RhinoScan software is equipped with a log for storing system activity and 
errors in the system. The log contains information on both normal and abnormal 
conditions in the measuring unit.

EXAMPLE OF THE 
SYSTEM LOG

The system log opened in WordPad looks like this:

USE OF THE SYSTEM 
LOG

It is strongly recommended to send the system log to your distributor, when you 
experience any problems with the RhinoScan program.

VIEWING THE SYSTEM 
LOG 

You can view the system log anytime by following this procedure:

To view the system log:

1 Either: 

• Select File → View System Log.

Or: 

• Use the Windows Explorer by browsing to the file using the path: 

c:\Program Files\Rhinometrics\Rhin98\Log.txt

The log file is opened.
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10.2 Trouble-shooting Communication with an SRE2000

If you receive this error message:

you must check if the software configuration matches your hardware.
To view the system log first, click Yes. The system log is described in 
section 10.1 ’Viewing the System Log’ on page 89. 

10.3 Trouble-shooting Initialization Warnings

If you receive an initialization warning you need to re-initialize the probe. See 
section 5.5 ’Trouble-Shooting Initialization Errors and Warnings’ on page 27.

10.4 Trouble-shooting Printing

If the print of a graph does not look satisfying, please check the printer set-up by 
following this procedure:

To trouble-shoot communication with an SRE2000:

1  a)  Select Tools → Options → Hardware tab.

 b)  Check that the proper DSP board type is selected.
 c)  Check that the selected COM port or ISA address is correct.
 d)  Check that the number in the DSP board field is the number on the 
hardware diskette, from which you have installed the hardware key. 

2 Check that the power on the measuring instrument is turned on.

3 Ensure that the SRE2000’s serial cable is properly connected to the serial 
port of the PC.
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To check the printer setup:

1  a)  Choose File → Printer Setup... 
The Print Setup window appears.
 b)  Check that the printer settings are correct.
 c)  Click OK.
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Chapter 11 Upgrading the RhinoScan Software

IN THIS CHAPTER This chapter contains information about how to upgrade your RhinoScan software 
including how to transfer the contents of the database.

11.1 Transferring the Contents of the Database when Upgrading

ABOUT THE NEW 
VERSION OF THE 
DATABASE

If you are upgrading the RhinoScan software from a version 2.5 or older, the con-
tents of your old database can be transferred (migrated) in an easy way. For fur-
ther information about the new version of the database, see “Database Principle” 
on page 59.

NOTE CHANGES  
WHEN TRANSFER-
RING DATA FROM AN 
OLDER VERSION

Since the structure of the database is altered compared to the RhinoScan soft-
ware versions 2.5 and older, please note the following changes when updating. 

Note: Users of the Patient mode of the old database will not experience
large changes when transferring data.

• For security reasons, the installation program makes a copy of your old 
 database before it is migrated. For this purpose, you need some free space on
 the PC’s hard disk. In general, you need the database’s size plus 25 MB free
 space. If there is not enough free space, you will get a warning.

• A copy of the old database is placed in the same folder as the Rhino.exe file
 named database.OLD. The default path is in English Windows: 
 C:\Program Files\RhinoMetrics\Rhin98.

• The name of the Examiner is reduced to initials of 2-5 characters length.
 If your database contained two or more examiners with identical names, the
 program automatically creates unique initials. 

• The hierarchic browser mode structure with folders and cases does not exist
 in the new version of the database. Folders and cases are replaced by one
 property connected to the examination: Case. When existing folders and 
cases
 are migrated, they are placed as Examinations with the property Case named      
 as: <folder name>/<case name>.

     To locate the examinations without patient (previous folders and cases):
     - See section 8.4 ’Viewing Patients and Examinations’ on page 68.
    To append a patient to an examination without patient:
     - See section 8.1.3 ’Appending a Patient to an Examination’ on page 63.

UPDATING THE SOFT-
WARE AND 
MIGRATING THE 
DATABASE

This procedure describes how to update the RhinoScan software and migrating 
the old database.

To update the RhinoScan software and migrate the database:

1 Before you start the update, ensure that you have enough free disk space 
on the PC’s hard disk. 

Note: You need free hard disk space of the database’s size plus 25 MB. 

2 During migration of the old database, the names of the examiners are 
reduced to initials. If you want to create these initials yourself, do it before 
updating.
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11.2 Upgrading the RhinoScan Software on an SRE2100

UPGRADING PROCE-
DURE FOR AN 
SRE2100

The RhinoScan software is supplied on a CD-ROM only. Since the SRE2100 
is not normally equipped with a CD-ROM drive, you must therefore copy the 
program to floppy disks on a PC with a CD-ROM drive and install the software on 
the SRE2100 from the disks.

3 Insert the RhinoScan software CD-ROM in the PC. 

Note: If you have an SRE2100 without a CD-ROM drive, you must first 
copy the CD-ROM to disks, see section 11.2 on page 94. Insert the disks.

4 Click Update in the installation main window. 

The installation of the software begins. Follow the instructions on the 
screen. Please refer to section 2.3 ’Installing the Software on an External 
PC for SRE2000’ on page 7.

5 Double-click on the Rhino icon to start the program.
If there is not enough free disk space, a warning appears. See step 2 and 
“NOTE Changes when transferring data from an older version” on 
page 93.

6 Click OK to confirm the migration of the database. 

The RhinoMetrics splash window appears. Depending on the size of the 
database, it will be visible for a couple of minutes, saying “Migrating Data-
base...” When the migration is finished, the Select Measure Type window 
is shown and the updated version of the RhinoScan program is ready to 
use.

7 Verify that the contents of the database is identical with the contents of the 
old database.

To update the RhinoScan software and migrate the database:
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Note: You need seven empty floppy disks to perform the software upgrade.

To create a set of disks and install them on the SRE2100:

1 Insert the RhinoScan software CD-ROM on a computer with a CD-ROM 
drive.The installation main window appears:

For a description of the several options, see “Functions on the Installation 
CD-ROM” on page 7.

2 Click on Copy Disks.

3 Insert an empty floppy disk in the A drive and click OK.

4 Follow the instructions on screen. When the copying is finished, you 
should have a set of floppy disks labelled 1 to 7.

5 To upgrade the software on the SRE2100:
 a)  Close all running programs on the SRE2100 instrument.
 b)  Insert the floppy disk labelled 1 in the instrument’s disk drive.
 c)  Select Run... from the Windows Start menu.
 d)  Enter A:setup in the Run window and click OK.
 e)  Follow Step 2 to 6 in section 2.3 ’Installing the Software on an External 
PC for SRE2000’ on page 7.
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Index

A
Accuracy 32
Analysing functions

activating 45
Analysis lines

moving 50
using the 50
viewing 49

Analysis mode 45
Archiving examinations 79

B
Background noise 19, 29

C
Cleaning the equipment 15
Cleaning tissues 15
COM port 6, 86
Creating a new patient 60
Cross-sectional area 32

exact values 33
Curves

activating 49
calculating mean curve 54
calculating standard deviation 54
changing the colour and style of 52
example of erroneous 31
example of leakage 30
inverting and scaling 54
name format 51
renaming 51
selecting 49
switching between 49
viewing data for 49

D
Database

browser mode 93
creating a new patient 60
deleting a patient 64
entering a new dianogsis 66
exporting patients 77
filters 76
grouping 74
importing data 81
patient mode 59, 93
sorting patients and examinations 72
structure 59
transferring data from old version to new 93
working in the 59

Date format, setting the 83
Deleting

a curve 51
a patient 64
an examination 65

Detomization 32
Diagnosis

appending to a patient 67
creating a new 66

E
Editing patient data 62
Electrical ratings 85
Entering a diagnosis 66
Entering patient data 61
Equipment and maintenance 15
Evaluating results 30
Examination

appending a patient to 63
archiving 79
deleting an 65
exporting as text file 77
grouping and filtering 73
importing 81
importing data without a patient 59
list of recent loaded 47
loading 45
printing 57
properties table 69
saving 39
sorting 72
viewing 70
viewing single results 72

Exporting data 77
as an ASCII file 79
as text file 77

F
Filtering patients and examinations 73
F-keys, list of 41

G
Graph

printing 55
setting the colour 53
show and hide 43
viewing whole 48
zooming 47

Grouping patients and examinations 73

H
Hardware

environmental ranges 86
settings 86
specifications 85
SRE2000 5
SRE2100 11
versions iii

Hardware key 10
installing it with the software 8
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Hiding the graph 43

I
Importing

data 59
patients and examinations 81
Rhin2000 files 82

Initialization 39
loading an 24, 25
saving an 24, 25
temperature dependency 19
trouble-shooting 27

Initialization inaccuracy limit, setting the 24
Initialization pipe 16, 19
Initialization tube 17, 22
In-line editing 61, 62
Installing the Hardware key separately 10
Installing the software 7

L
Language, setting the 83
Leakage

detecting 29
effect on results 30
location 29

License code
entering 8, 13

Loading an examination 45
Locating the minimum cross-sectional area 49
Log file,viewing the 89

M
MCA1 42, 49
MCA2 42, 49
Mean curve 54
Measurement accuracy 33
Measurement accuracy bar 34

defining the 42
Measuring

accepted deviation 35
accuracy 32
errors 29
method 87
occluded nasal cavity, influcence on 32
tips to avoid leakage 30
use of nasal spray 32
with another Rhino module 41
with Mini Probe 36
with Standard Probe 33

Measuring tube 17, 24
Mini nose adapter 17, 37
Mini Probe 17

cleaning 17
initialization of 22
limitations in use of 29
measuring with 36

Minimum cross-sectional area 42
distance from nostril 49

see also MCA1 and MCA2
Minimum system requirements 5

N
Nasal occlusion 32
Nasal spray, effect on measurement 32
Nasal volume 49
New measurement 40
Noise 19, 29
Nomenclature in manual iii
Nose adapter 30, 33

P
Parallel cavity 30
Patient

append to an examination 63
appending a diagnosis to 67
creating new 60
deleting 64
editing data 62
entering data for 61
exporting 77
grouping and filtering 73
importing 81
properties table 69
sorting 72
viewing data and comments for 69

Patient Data window
advanced view 68
predefined view 68

Patient report
printing 57

Patient safety, see Safety
Pausing a measurement 40
Power supply cord 85
Print preview 56
Printing 55

examinations 57
patient reports 57
trouble-shooting 90

Probe
see Standard Probe or Mini Probe

Probe A input
SRE2000 6
SRE2100 12

Program options 42

R
Reinitialization 19, 29, 41
Renaming a curve 51
Results

avoiding errors in 29
deviation in, cause of 30
evaluating 30
exporting as text file 77
printing 57
viewing listed of an examination 72

Results, see also Curves
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RhinoScan software
compatible Windows operating systems 6
entering the license code 8, 13
installing on an external PC 7
items 5, 11
prerequisite knowledge iii
upgrading 93

S
Safety

accessory equipment 2
classifications 85
if device has been exposed to water 15
information 1
manufacturer’s responsability 2
SRE2000 in patient environment 6
SRE2100 and external equipment 12
symbols on the instrument 2

Saving a measurement 39
SealGel 17, 30
Security information, see Safety 1
Serial cable 6
Serial port 90
Setting the inaccuracy limit 28
Short-cut keys 41
Software

compatible Windows operating systems 6
items 5, 11
minimum system requirements for PC 5
opgrading 93
setup on SRE2100 13

Software license code 8, 13
Sorting patients and examinations 72
Sources 29
SRE2000

cleaning 15
communication error 90
connecting the instrument 6
getting started 5
hardware description 5
pulseoximeter input 6

SRE2100
cleaning 15
connecting a printer to 12
connecting the instrument 12
description 11
following the Windows 98 setup procedure 13
getting started 11
upgrading software on 94

Standard deviation 54
Standard Nose 33
Standard Probe 16

cleaning 16
initialization 19
limitations in use of 29
measuring 33

Starting a new measurement 40

Stastistical curves 54
System log,viewing the 89
Systematic error 30

T
Temperature ranges 86
Trouble-shooting

communication with SRE2000 90
initialization 27
printing 90

U
Units, setting the 83
Upgrading the software 93

V
Viewing curve data 49
Viewing patient properties 69
Volume 49

W
Warnings 1
Windows

compatible platforms 6
setup procedure (SRE2100) 13

Z
Zooming 47
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